Egloos | Log-in


nmap 7.70 update

최근에 nmap이 업데이트되었는데, 역시, ubuntu에서는 apt upgrade가 지원안되어서 source로 인스톨하였다.


혹시, 보안관련 체크일이 필요한 분들이라면, nmap을 업그레이드하기를 권한다.

nmap의 기본 기능만으로도 유익하기는 하지만, 다양한 nse script를 사용하는 편리함도 있는데, 

이전 nmap에서는 실행이 되지 않는 스크립트들이 있다.


찾아보니, 최신의 NSE(Nmap Script Engine) script에서 lua 5.3에서 부터 지원되는 operator('//')를 쓰는 경우가 있는데, 이게 old versin nmap에서는 안된다.

nmap은 lua interpreter를 nmap 내부에 내장한걸 쓰기 때문에, 시스템의 lua를 업데이트하는 것만으로는 적용이 되지 않기 때문이다.


http://seclists.org/nmap-announce/2018/0


by 코퍼스 | 2018/04/11 15:11 | IT | 트랙백 | 덧글(0)

트랙백 주소 : http://corpus.egloos.com/tb/7403012
☞ 내 이글루에 이 글과 관련된 글 쓰기 (트랙백 보내기) [도움말]

:         :

:

비공개 덧글

◀ 이전 페이지          다음 페이지 ▶